There was an error updating the remote database configuratio

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There was an error updating the remote database configuratio

Postby Lance » Wed Feb 13, 2008 12:43 am

There was an error updating the remote database configuration file.

SYMPTOMS
While attempting to complete the Create Admin Database dialog to connect an AdministrateIT installation to the/its server - and perhaps under certain other circumstances - AdministrateIT generates this error after OK is pressed in the Create Admin Database dialog and even though the dialog can connect etc correctly.

CAUSE
In all known case this was due to:
    * Both ShowConfig and AdministrateIT running at the same time on the same machine, or
    * Having one or the other running and there also being an orhpaned copy of one or the other applications in the process space
    * Some unknown process or file system glitch interfering with write access to the configuration file
    * The logged-on Windows ID does not have sufficient privelages to read/write the files
    * It is possible that Windows Fast User Switching could trigger this error


An orphaned application is one whose User Interface (presence on the screen) is no longer visible but which otherwise exists as an active process on the machine. Orphaned programs can be problematic because they have no UI with which to interact or exit them.

ShowConfig is an application that is installed with the ILMS system into
c:\\program files\\iluminar technologies\\ilms, and which allows the viewing and editing of the ILMS Server connection information. DO NOT edit the configuration UNLESS certain the information to be edited/replaced is correct or instructed to do so by a Technical Support staff member.

RESOLUTION
If AdministrateIT and/or ShowConfig are running with a visible UI, exit those running instances of the two applications.

Then:
Start the TaskMgr by right clicking on the System Tray and selecing Task Manager from the context menu.
Click the Processes tab
Click on the Image Name column heading to sort the processes by name
Search for either of AdministrateIT.exe or ShowConfig.exe
If either is found, right click on it and select End Process

Assuming that neither of AdministrateIT nor ShowConfig is running on the machine, it should be possible to complete the Remote Database configuration exercise by starting AdministrateIT and completing the Create Admin Database dialog exercise, or, if that fails or one wants to perform the exercise another way, start ShowConfig, press the Edit button, and then enter the appropriate information into ShowConfig and finally saving the configuration information.

IMPORTANT NOTE: If one is not confident in being able to complete any of the above steps, if there are other issues, or if the above steps are completed but the situation is NOT resolved, please contact Technical Support for further assistance.

The configuration files in question are located at:
c:\\documents and settings\\application data\\iluminar technologies\\...
for most versions of Windows, and
C:\\ProgramData\\Iluminar Technologies\\...
for Vista (subject to verification)

MORE INFORMATION
Some of the steps above are relatively advanced Windows user activities, in particular using the Windows Task Manager to terminate processes.

Again, If one is not confident in being able to complete any of the above steps, if there are other issues, or if the above steps are completed but the situation is NOT resolved, please contact Technical Support for further assistance.

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APPLIES TOAdministrateIT ManageIT LearnIT Networked install configuration file
Lance
 
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Joined: Thu Oct 11, 2007 4:38 pm

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