StageIT License Management error after upgrading from version 1.1 or earlier
SYMPTOMS
When trying to access the License Manager, the following error is generated in the web browser…
Server Error in '/ITLicenseManager' Application.
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Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.
Parser Error Message: The type 'ITLicenseManager.Global' is ambiguous: it could come from assembly 'C:\\Program Files\\Iluminar Technologies\\LicenseManager\\ITLicenseManager\\bin\\ITLicenseManager.DLL' or from assembly 'C:\\Program Files\\Iluminar Technologies\\LicenseManager\\ITLicenseManager\\bin\\ITLicenseManager_deploy.DLL'. Please specify the assembly explicitly in the type name.
Source Error:
Line 1: <Application>
Source File: /ITLicenseManager/global.asax Line: 1
CAUSE
“ITLicenseManager_Deploy.dll” is the correct file that should be used by the program and “ITlicenseManager.dll” is from a previous version of StageIT that is now in conflict.
RESOLUTION
If the proper procedure (below) is followed when upgrading StageIT, the installation should complete without error and the program should function correctly.
1. Insert the StageIT 1.3 (or later) CD
2. Follow the onscreen prompts and choose the option “Restore the software for the entire system”.
3. Select the desired StageIT components and proceed with the installation.
If however, version 1.1 or earlier is first uninstalled using “Add or Remove Programs” (2K, XP) or “Programs and Features” (Vista), Then there will be files left over that must be manually removed before installing version 1.3 or later.
Procedure to manually removing StageIT…
1. Remove Iluminar “StageIT Instructor”, “StageIT Student”, and “License Management” using \"Add or Remove Programs” (2K, XP) or “Programs and Features” (Vista).
2. Navigate to - C:\\Program Files\\Iluminar Technologies – and delete the “StageIT” and the “License Manager” folders.
3. If using 2k or XP… Navigate to - C:\\Documents and Settings\\All Users\\Application Data\\Iluminar Technologies – and delete the “StageIT” folder.
4. If using Vista… Navigate to - C:\\ProgramData\\Iluminar Technologies – and delete the “StageIT” folder.
The StageIT program and the associated License Management utility (version 1.3 or later) should now install and function correctly.
